Stargate View is Not Caching

Post Reply
AliUgur
Posts: 58
Joined: Tue Aug 05, 2014 2:13 pm
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: Excel 2013

Stargate View is Not Caching

Post by AliUgur »

Hi,

I tried to use Stargate View for a large cube for the first time but couldn't create it. I debugged it also from tm1s-log.properties and I am getting information about it like at the bottom:

After a new stargate is created, it destroys it a couple of minutes later. Also, I am not able to see information like the Number of Stored Views or Memory Used For Views in the }StatsbyCube cube.


As I check from the link: https://everanalytics.wordpress.com/201 ... _deepdive/

I need to see "ViewStorage::AddStargate: Stargate (Some_Memory_Address) added to ViewStorage (Memory_Address)" this information if my view is set as Stargate View but I couldn't see it in the log files.

Any help would be greatly appreciated.
Attachments
Capture.JPG
Capture.JPG (128.3 KiB) Viewed 576 times
User avatar
gtonkin
MVP
Posts: 1072
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.9.10; PAW 2.0.71
Excel Version: Office 365 64-bit
Location: JHB, South Africa
Contact:

Re: Stargate View is Not Caching

Post by gtonkin »

What version of PA are you running? I had issues previously.
What VMM and VMT settings have you allocated to the cube?
AliUgur
Posts: 58
Joined: Tue Aug 05, 2014 2:13 pm
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: Excel 2013

Re: Stargate View is Not Caching

Post by AliUgur »

Hi gtonkin,

Thanks for your reply.

PLANANALYTICS_version=PLANANALYTICS-AW64-ML-RTM-10.2.5200.234-0.

And I put VMT as 0 to create the Stargate view and VMM as 30000000000. Also, I tried the lower VMMs (5 GB, 10 GB, etc.). But, I was getting the same information as destroying the Stargate view. I will fix the VMM value after I create the stargate view but for now, I put the highest VMM as much as I can.

These are the values I got when I start the Performance Monitor.
Attachments
Capture1.JPG
Capture1.JPG (40.3 KiB) Viewed 492 times
lotsaram
MVP
Posts: 3571
Joined: Fri Mar 13, 2009 11:14 am
OLAP Product: TableManager1
Version: PA 2.0.x
Excel Version: Office 365
Location: Switzerland

Re: Stargate View is Not Caching

Post by lotsaram »

If VMT = 0 then the default value will be used which I believe is 5 seconds. So if the view construct takes less than 5 seconds then nothing will be cached.
Please place all requests for help in a public thread. I will not answer PMs requesting assistance.
AliUgur
Posts: 58
Joined: Tue Aug 05, 2014 2:13 pm
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: Excel 2013

Re: Stargate View is Not Caching

Post by AliUgur »

Hi lotsaram,

thanks for your reply.

I set the VMT 2 or 3 before and had the same issue. The view that I try to cache as Stargate View is opening around 15-20 seconds.

I tried many things to set VMT and VMM but couldn't create a stargate view.
User avatar
gtonkin
MVP
Posts: 1072
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.9.10; PAW 2.0.71
Excel Version: Office 365 64-bit
Location: JHB, South Africa
Contact:

Re: Stargate View is Not Caching

Post by gtonkin »

Just looking at your TM1 version, looks like you are on 10.2.2 base - IIRC, this was awful and FP4 fixed many, many issues.
If you cannot test on a current version like PA 2.0.9.14 then suggest you try upgrade to 10.2.2 FP4 to see if this resolves.
AliUgur
Posts: 58
Joined: Tue Aug 05, 2014 2:13 pm
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: Excel 2013

Re: Stargate View is Not Caching

Post by AliUgur »

Hi gtonkin,

I tried to create Stargate View on my local computer on the Planing Sample instance which is an IBM sample database. I had the same error.

My Pa version is 11.8.100.13

I used the "plan_BudgetPlan" cube and created a view with all elements from all dimensions which is opening around 7 seconds.

As a VMT and VMM settings, I gave VMT as 1 second and VMM as 1GB to see if it will create StargateView. But, I had the same error.

Maybe, I am missing a point to set up for creating Stargate View but I couldn't find any other information about it.

Thanks for the help.
Attachments
Capture4.JPG
Capture4.JPG (43.82 KiB) Viewed 434 times
Capture3.JPG
Capture3.JPG (73.2 KiB) Viewed 434 times
User avatar
gtonkin
MVP
Posts: 1072
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.9.10; PAW 2.0.71
Excel Version: Office 365 64-bit
Location: JHB, South Africa
Contact:

Re: Stargate View is Not Caching

Post by gtonkin »

A couple more things to check:
  • Could you share your TM1S.cfg, could be something in there that needs tweaking - do not need to see server names, data dirs etc. MTQ is critical. Also need to look for entries like MTQ.SingleCellConsolidation=false, MTQ.CTreeWorkUnitMerge, MTQ.MultithreadStargateCreationUsesMerge etc.
  • Are you opening the view via the cube viewer, not running a TI?
  • Was the view created manually or via TI? If TI, did you use ViewConstruct?
  • VMM of 1 may be too short - >3 is probably more suitable - have you tried slightly higher values again in PA?
  • Have you tried switching dimensions around between Context, Rows and Columns to see if there is a difference?
  • Is the view only Leaf elements, only C levels or a mixture?
Cannot think of more right now but maybe with the above and your feedback other members can offer further advice.
AliUgur
Posts: 58
Joined: Tue Aug 05, 2014 2:13 pm
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: Excel 2013

Re: Stargate View is Not Caching

Post by AliUgur »

Hi gtonkin,

Thanks for your help and the questions.

I started to use and understand Stargateview on a simple database. So, I used the IBM Planning Samples instance and on my local PA(11.8.100.13) I created a view(manually) that uses plan_BudgetPlan cube (Planning Samples database). I opened all the dimension items(C and N levels) and the view opens around 7-8 seconds.

To answer your questions;

I didn't use MTQ parameters to create a Stargate View. Should I use them? (I didn't see it on the documentation of IBM and the forums.)
Additionally, I created the view manually and opened it from the cube viewer. By the way, I used the ViewConstruct function also but didn't work in my case. I tried different VMT settings like 3,4,5 etc.

Lastly, I changed the dimension places as like I set a dimension as a title dimension, but nothing changed.

If I can create it on this instance then I will try it for my big cube.

Tm1s file:

ServerLogging=F
SecurityPackageName=Kerberos
IntegratedSecurityMode=1
UseSSL=T
ServerName=Planning Sample
DataBaseDirectory=.
AdminHost=
PortNumber=12345
HTTPPortNumber=12354
ClientMessagePortNumber=
Savetime=
Downtime=
LicenseMetricTime=
ProgressMessage=True
AuditLogOn=F
AuditLogMaxFileSize= 100 MB
AuditLogUpdateInterval=60
PersistentFeeders=F
ParallelInteraction=T
IPVersion=ipv4
ServerCAMIPVersion=ipv4
EnableNewHierarchyCreation=T
EnableTIDebugging=T

PerformanceMonitorOn=T
UseStargateForRules=F (I added this parameter at the end to see if it will have an effect, but I tried everything before this parameter also.)
User avatar
gtonkin
MVP
Posts: 1072
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.9.10; PAW 2.0.71
Excel Version: Office 365 64-bit
Location: JHB, South Africa
Contact:

Re: Stargate View is Not Caching

Post by gtonkin »

As a start try add MTQ to the TM1s.cfg:
MTQ=ALL

This article may also help:
https://www.ibm.com/support/pages/tip-a ... cognos-tm1
Post Reply