Active Form reports not generating ending columns PA 2.0.9.14 & PA 2.0.9.13

Post Reply
shahhere
Posts: 10
Joined: Thu Mar 03, 2022 7:13 pm
OLAP Product: IBM PA
Version: 2.0.9.12
Excel Version: O365

Active Form reports not generating ending columns PA 2.0.9.14 & PA 2.0.9.13

Post by shahhere »

We upgraded to version 2.0.9.14 & ever rolled back to PA 2.0.9.13 (From 2.0.9.04)

After the upgrade most of our active forms did not generate correctly and noticed that the ending part of the reports was not generating the information down on an Active Form. The more If condition columns in between the DBR/DBRW were present the less ending columns would be missing.

Tested PAfE and its fine and finally rolled back to 2.0.9.12 and not seeing this behavior.

Anyone run into this or have any insight on options?

Shahhere

PS. IBM has confirmed that they are able to reproduce this bug and have alerted that they have tickets indicating this as an issue from other customers.
Last edited by shahhere on Tue Aug 09, 2022 11:57 am, edited 1 time in total.
declanr
MVP
Posts: 1792
Joined: Mon Dec 05, 2011 11:51 am
OLAP Product: Cognos TM1
Version: PA2.0 and most of the old ones
Excel Version: All of em
Location: Manchester, United Kingdom
Contact:

Re: Active Form reports not generating ending columns PA 2.0.9.14 & PA 2.0.9.13

Post by declanr »

If you add additional columns outside of an active form you need to update the named range TM1RPTFMTRNG to include your new columns. This tells TM1 to dynamically update the relevant rows it adds in under that column when the form is refreshed/rebuilt.
Declan Rodger
shahhere
Posts: 10
Joined: Thu Mar 03, 2022 7:13 pm
OLAP Product: IBM PA
Version: 2.0.9.12
Excel Version: O365

Re: Active Form reports not generating ending columns PA 2.0.9.14 & PA 2.0.9.13

Post by shahhere »

Just to be clear; existing report that was working is not working and rendering all the columns post upgrade. All of the range work is correct.

Are you saying adding the extra columns and then making the range bigger will work?

Either way we'd have to touch hundreds of reports btw.

Shahhere

PS. IBM confirming that these 2 versions have the bug I mentioned and also has another customer with the issue as well.
MarenC
Regular Participant
Posts: 236
Joined: Sat Jun 08, 2019 9:55 am
OLAP Product: Planning Analytics
Version: Planning Analytics 2.0
Excel Version: Excel 2016

Re: Active Form reports not generating ending columns PA 2.0.9.14 & PA 2.0.9.13

Post by MarenC »

Hi,
Title says it all but
FYI - the title did not say it all, not even close!

Maren
shahhere
Posts: 10
Joined: Thu Mar 03, 2022 7:13 pm
OLAP Product: IBM PA
Version: 2.0.9.12
Excel Version: O365

Re: Active Form reports not generating ending columns PA 2.0.9.14 & PA 2.0.9.13

Post by shahhere »

Sure; updated more information in the body of the first post to clarify the issue and the update from IBM.

Shahhere
nanobaka
Posts: 29
Joined: Tue Jul 26, 2011 4:24 pm
OLAP Product: PA Local
Version: 2.0.9.14
Excel Version: 2016

Re: Active Form reports not generating ending columns PA 2.0.9.14 & PA 2.0.9.13

Post by nanobaka »

I just found out about this problem in the worst way: after the production server is upgraded and a user (our boss) complained. It was not obvious in our environment because it does not affect TM1Web. I am going to pester IBM to get them fix this. I also need to do a better job testing. :oops:
shahhere
Posts: 10
Joined: Thu Mar 03, 2022 7:13 pm
OLAP Product: IBM PA
Version: 2.0.9.12
Excel Version: O365

Re: Active Form reports not generating ending columns PA 2.0.9.14 & PA 2.0.9.13

Post by shahhere »

nanobaka wrote: Thu Aug 11, 2022 8:13 pm I just found out about this problem in the worst way: after the production server is upgraded and a user (our boss) complained. It was not obvious in our environment because it does not affect TM1Web. I am going to pester IBM to get them fix this. I also need to do a better job testing. :oops:
I am on the same boat as you as I upgraded all of my production instances and ironically this isnt affecting newer reports or all reports either.

TM1Web/PAfE/PAW were not affected by this.

Only Perspectives is.

Version .12 is working fine for use btw and thats what I revered all prods back to including all of my citrix VDIs (a lot of hours wasted).

Shahhere

PS. What version did you jump from? Maybe there are some similarities.....
nanobaka
Posts: 29
Joined: Tue Jul 26, 2011 4:24 pm
OLAP Product: PA Local
Version: 2.0.9.14
Excel Version: 2016

Re: Active Form reports not generating ending columns PA 2.0.9.14 & PA 2.0.9.13

Post by nanobaka »

shahhere wrote: Thu Aug 11, 2022 8:26 pm PS. What version did you jump from? Maybe there are some similarities.....
I was upgrading from 2.0.9.11. We tested it on our dev server and things that are most important to us, TI processes and TM1Web, seemed to work. Our boss is one of the very few who use Perspectives and his usage slipped through our testing. Ugh.

I "rolled back" (aka wipe and reinstall) to 2.0.9.12 on our dev server after reading this thread and confirmed the problem went away.
Post Reply