Tm1 PAW Start.bat exit with code 0

Post Reply
kavitha2002
Posts: 122
Joined: Sat May 05, 2018 11:48 am
OLAP Product: tm1
Version: 10.3.10100.8
Excel Version: 14

Tm1 PAW Start.bat exit with code 0

Post by kavitha2002 » Wed Mar 06, 2019 2:13 pm

Hello Everyone,

I have to setup the environment to execute the PAW in Windows 10 so installed Docker toolbox 17.6.02-ce, earlier its was working properly but now its creating the default and paw machine but start.bat exit with code 0. In browser, IP address cant be reached for IBM planning Analytics Adminstration agent..


Kindly provide me some workaround because its very urgent..need to fix it :(

declanr
MVP
Posts: 1605
Joined: Mon Dec 05, 2011 11:51 am
OLAP Product: Cognos TM1
Version: PA2.0 and most of the old ones
Excel Version: All of em
Location: Manchester, United Kingdom
Contact:

Re: Tm1 PAW Start.bat exit with code 0

Post by declanr » Wed Mar 06, 2019 4:03 pm

Download windowscontainernetworking-loggingandcleanupaide.ps1 from github and run it with the cleanup option, see if that helps.

I run workspace on a Server 2016 VM on my personal machine rather than having it directly on the PC but I believe it’s not ideal to run it on a laptop (which I assume you are) where the Network is regularly changing. Running the ps1 above should cleanup the docker containers and their history, so if it is an issue where it’s expecting a certain IP etc then it should resolve it. If that doesn’t work try and have a look through the logs and put that info here - someone might be able to point you in the right direction then.


Edit - I also recommend that when you do get it running properly always make sure to stop all of the services in the admin console before turning off your pc or changing networks etc.

kavitha2002
Posts: 122
Joined: Sat May 05, 2018 11:48 am
OLAP Product: tm1
Version: 10.3.10100.8
Excel Version: 14

Re: Tm1 PAW Start.bat exit with code 0

Post by kavitha2002 » Thu Mar 07, 2019 1:15 pm

Thanks for your reply @declanr

But I have installed in Windows 10 Pro, so its something different. I have resolved it by adding the below line in start.bat

SET COMPOSE_TLS_VERSION=TLSv1_2

ref:

dr.nybble
Posts: 118
Joined: Wed Aug 17, 2011 3:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2007

Re: Tm1 PAW Start.bat exit with code 0

Post by dr.nybble » Thu Mar 07, 2019 3:07 pm

This is because by default the latest boot2docker.iso image is used for the VM. At some point Docker has updated it to require TLS 1.2, whereas with the older version of Docker Toolbox (which containers the docker.exe client) defaults to an earlier TLS version. Adding that environment variable is the right fix.

kavitha2002
Posts: 122
Joined: Sat May 05, 2018 11:48 am
OLAP Product: tm1
Version: 10.3.10100.8
Excel Version: 14

Re: Tm1 PAW Start.bat exit with code 0

Post by kavitha2002 » Fri Mar 08, 2019 8:08 am

Nice explanation:) thanks

Is there any good document or video for docker, docker commands and docker supported OS info?

Post Reply