ClassFactory error in Excel

ClassFactory error in Excel

Postby ps_in_atl » Tue Aug 02, 2011 11:35 am

I have a user who just installed 9.5.1 and is getting the following error upon opening Excel (2007): "System Error &H80040111 (-2147221231). ClassFactory cannot supply requested class". It must be related to the add-in, but no idea why.

Any help?
ps_in_atl
 
Posts: 12
Joined: Fri Apr 01, 2011 12:55 pm
OLAP Product: Cognos TM1
Version: 10.1.1 x64_MS Server 2008
Excel Version: Excel 2007

Re: ClassFactory error in Excel

Postby thec0dy » Tue Oct 18, 2011 7:32 pm

Hi,

Did you ever figure out the fix to this? I am having the same issue.
thec0dy
 
Posts: 2
Joined: Tue Oct 18, 2011 7:31 pm
OLAP Product: Cognos Perspectives
Version: 9.5.1
Excel Version: 2007

Re: ClassFactory error in Excel

Postby jim wood » Tue Oct 18, 2011 7:51 pm

Have you tried the good old fall back in these situations.... re-install both (or just TM1) excel and TM1?
Struggling through the quagmire of life to reach the other side of who knows where.
ACG TM1 / Essbase Consulting
OS: Windows 7 64-bit. TM1 Version: 10.2.2
User avatar
jim wood
Site Admin
 
Posts: 2750
Joined: Wed May 14, 2008 1:51 pm
Location: 1639 Route 10, Suite 107, Parsippany, NJ, USA
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: 2007

Re: ClassFactory error in Excel

Postby ccierpik » Tue Apr 17, 2012 2:14 pm

I wanted to check and see if anyone has come up with a solution for this. Everything was working fine and when working with an embedded excel file in powerpoint (no TM1 references, but I did have another workbook open with TM1) it crashed and from that point on I get the reference error message. I've uninstalled office and tm1, deleted *.exd files and nothing seems to work. I'm using Excel 2007 and TM1 9.5.1. Thanks for your help.
ccierpik
 
Posts: 16
Joined: Thu May 15, 2008 12:59 pm

Re: ClassFactory error in Excel

Postby ParisHilton » Wed Apr 18, 2012 12:09 pm

Hi , what version of windows are you using?

We've had a recent problem where a windows 7 update has caused nasties.


P
xx
“The way I see it, you should live everyday like its your birthday”


TM1 9.5 Cognos BI 8.4 Excel 2007. 128GB Ram. E7450@2.40Ghz -24 core. Fluffy white dog.
ParisHilton
 
Posts: 73
Joined: Fri Apr 23, 2010 11:35 am
OLAP Product: Tm1
Version: 9.5
Excel Version: 2007 2010

Re: ClassFactory error in Excel

Postby ccierpik » Wed Apr 18, 2012 3:11 pm

It's Vista. I finally got it to work after reinstalling Excel and TM1 and then copying in MSComCtl.ocx. I had tried that before, but I guess I just needed to do a clean install first.
ccierpik
 
Posts: 16
Joined: Thu May 15, 2008 12:59 pm


Return to Cognos TM1

Who is online

Users browsing this forum: Gabor, Google [Bot], TrevorGoss, Yahoo [Bot] and 11 guests

Loading