Active Form error - The clipboard cannot be emptied.

Post Reply
awood
Posts: 5
Joined: Mon Jul 09, 2012 11:58 am
OLAP Product: TM1
Version: 9.5.2 FP2
Excel Version: 2010

Active Form error - The clipboard cannot be emptied.

Post by awood » Tue Jul 10, 2012 8:48 am

When accessing TM1 via Citrix and trying to navigate an active form the following error is displayed in Excel 2010.
“The Clipboard cannot be emptied. Another program might be using the Clipboard”

This error displays each time a user drills down in an active form, the more levels in the hierarchy the more times the error displays.

The version of Citrix we are using is XenApp 5.0.
The server TM1 is running on is Windows Server 2003 SP2.
Client PCs are running Windows 7 with excel 2010.
TM1 version is 9.5.2 FP2.

We have found a work around to the problem, the error disappears if:
Clipboard mapping is disabled in ICA-tcp Properties.
The problem with this workaround is that it disables the ability to do a standard copy and paste outside of the users Citrix session which is unworkable.
The clipboard error does not occur in RDP or if using a locally installed version of TM1.

Has anyone experienced a similar problem in Citrix and if so were you able to stop the clipboard error appearing?

Any ideas or suggestions would be much appreciated.

Paul Segal
Community Contributor
Posts: 244
Joined: Mon May 12, 2008 8:11 am
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: Active Form error - The clipboard cannot be emptied.

Post by Paul Segal » Tue Jul 10, 2012 9:28 am

FWIW, using active forms on my Citrix setup (6.0, Excel 2003, TM1 9.52 FP2) works fine. In my experience I am more likely to get this error using RDP than Citrix. The internetweb has a host of answers, although there doesn't seem to anything that works for everyone all the time. One thing might be worth trying - are there multiple installs sof Excel/Office on the Citrix server? i.e. a mix of 2010 and previous versions? If so, it could be worth uninstalling all the Excel/Office instances and then re-installing 2010.
Paul

awood
Posts: 5
Joined: Mon Jul 09, 2012 11:58 am
OLAP Product: TM1
Version: 9.5.2 FP2
Excel Version: 2010

Re: Active Form error - The clipboard cannot be emptied.

Post by awood » Tue Jul 10, 2012 1:52 pm

Hi Paul.

Thanks you for your reply. Active forms worked fine for us until we upgraded from Excel 2003 to Excel 2010. Yes we are running multiple versions of Excel in Citrix. I will try your suggestion and see if a clean install of excel 2010 only fixes the problem. Tell you if this is successful.

awood
Posts: 5
Joined: Mon Jul 09, 2012 11:58 am
OLAP Product: TM1
Version: 9.5.2 FP2
Excel Version: 2010

Re: Active Form error - The clipboard cannot be emptied.

Post by awood » Wed Jul 11, 2012 8:08 am

Hi Paul.

Bad news, I have confirmed that the Citrix servers are only running Excel 2010 and no other version of Excel exists on the server. Thanks for the idea but it looks like it is back to the drawing board.

lotsaram
MVP
Posts: 3094
Joined: Fri Mar 13, 2009 11:14 am
OLAP Product: TM1, CX
Version: TM1 10.2.2 PA 2.0x
Excel Version: 2010 2013 365
Location: Switzerland

Re: Active Form error - The clipboard cannot be emptied.

Post by lotsaram » Wed Jul 11, 2012 9:56 am

We also have this issue with Excel 2010 and active forms (on standard desktop not Citrix or rdp) but are just "living with it"

Paul Segal
Community Contributor
Posts: 244
Joined: Mon May 12, 2008 8:11 am
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: Active Form error - The clipboard cannot be emptied.

Post by Paul Segal » Wed Jul 11, 2012 10:26 am

awood wrote:Hi Paul.

Bad news, I have confirmed that the Citrix servers are only running Excel 2010 and no other version of Excel exists on the server. Thanks for the idea but it looks like it is back to the drawing board.
Oh well, I guess that would've been too easy.

Did you try the fix described in http://support.citrix.com/article/CTX086028/?

I'm going to be doing some testing on this on my Citrix servers in the near future, so we'll see if I come up with the same problem.
Paul

awood
Posts: 5
Joined: Mon Jul 09, 2012 11:58 am
OLAP Product: TM1
Version: 9.5.2 FP2
Excel Version: 2010

Re: Active Form error - The clipboard cannot be emptied.

Post by awood » Thu Jul 12, 2012 2:47 pm

Paul thanks once again for your suggestion I have passed the link over to our Citrix team. I will tell you if they have any success. Please tell me if you’re Citrix testing uncovers a similar problem.

awood
Posts: 5
Joined: Mon Jul 09, 2012 11:58 am
OLAP Product: TM1
Version: 9.5.2 FP2
Excel Version: 2010

Re: Active Form error - The clipboard cannot be emptied.

Post by awood » Fri Jul 13, 2012 7:11 am

Hopefully some light at the end of the active form tunnel. IBM have opened APAR:PM59930 to look at this problem.

User avatar
jameswebber
Community Contributor
Posts: 188
Joined: Sun Nov 21, 2010 8:00 pm
OLAP Product: Cognos Express 10
Version: CE 10.1.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Active Form error - The clipboard cannot be emptied.

Post by jameswebber » Mon Oct 29, 2012 8:38 am

Just wondering if anyone else has got a nice fix to this issue.
It seems to be the one issue I have at the moment stopping my Cognos Express upgrade from going live :cry:

User avatar
jameswebber
Community Contributor
Posts: 188
Joined: Sun Nov 21, 2010 8:00 pm
OLAP Product: Cognos Express 10
Version: CE 10.1.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Active Form error - The clipboard cannot be emptied.

Post by jameswebber » Tue Nov 06, 2012 10:39 pm

IBM gave me this:
They had a another customer who recently had the same issue
"We got Citrix XenApp 6.5 running in house and set it up with Excel 2010 and Perspectives 9.5.2 FP2.
I could easily reproduce the problem with an active form.
I did not have Outlook running on my machine but ran Excel locally.
It didn't happen every time but somewhere between 1 and 10 drills I would get the error.
I had the following setting put on in on the Citrix machine:
To enable read-only Clipboard Mapping, set the following registry key on each XenApp server.
Open the registry and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\Virtual Clipboard
Create a DWORD value with the value name ReadOnly and value data 1.
Restart the XenApp server.

There are slightly different instructions depending on version. See http://support.citrix.com/article/CTX124356
for more info.
So we are going to build a new citrix server with just CE on it and try this ReadOnly seting.

I proved this in principle by disabling the clipboard locally in citrix using local policy editor but this is a pants solution.

User avatar
tomok
MVP
Posts: 2464
Joined: Tue Feb 16, 2010 2:39 pm
OLAP Product: TM1, Palo
Version: Beginning of time thru 10.2
Excel Version: 2003-2007-2010-2013
Location: Atlanta, GA
Contact:

Re: Active Form error - The clipboard cannot be emptied.

Post by tomok » Wed Nov 07, 2012 12:26 am

jameswebber wrote:but this is a pants solution.
As opposed to a shirt solution????????
Tom O'Kelley - Manager Finance Systems
American Tower
http://www.onlinecourtreservations.com/

User avatar
Harvey
Community Contributor
Posts: 214
Joined: Mon Aug 04, 2008 4:43 am
OLAP Product: PA, TM1, CX, Palo
Version: TM1 8.3 onwards
Excel Version: 2003 onwards
Contact:

Re: Active Form error - The clipboard cannot be emptied.

Post by Harvey » Wed Nov 07, 2012 10:57 am

I had this issue inside a Microsoft Virtual Machine.

I know it's a different environment, but it was to do with the clipboard sharing service that the VM used, so it's probably related, since the modern MS VM actually uses remote desktop technology to provide interaction.

I found that if I killed a process called "rdpclip.exe" the error would go away, so I tried disabling clipboard sharing for the VM. That caused the error to disappear.

Of course, I lost the ability to cut and paste between my desktop and the virtual machine, but there must be something screwy about the way TM1 manipulates the clipboard, so it was the only way I could get Excel to remain stable.
Flow OLAP - thinking outside the cube.

User avatar
jameswebber
Community Contributor
Posts: 188
Joined: Sun Nov 21, 2010 8:00 pm
OLAP Product: Cognos Express 10
Version: CE 10.1.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Active Form error - The clipboard cannot be emptied.

Post by jameswebber » Thu Nov 08, 2012 9:24 pm

Yeah this is definitely a screwy way that TM1 uses the clipboard.
Still waiting for my new citrix server but very hopeful that it fixes it.


Pants like in underpants = rubbish by the way Tomok
http://news.bbc.co.uk/2/hi/uk_news/engl ... 585098.stm

User avatar
jameswebber
Community Contributor
Posts: 188
Joined: Sun Nov 21, 2010 8:00 pm
OLAP Product: Cognos Express 10
Version: CE 10.1.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Active Form error - The clipboard cannot be emptied.

Post by jameswebber » Sun Nov 18, 2012 7:00 pm

IBM have raised a new APAR for this
https://www-304.ibm.com/support/entdocv ... RXT&mync=E

No fix yet

User avatar
jameswebber
Community Contributor
Posts: 188
Joined: Sun Nov 21, 2010 8:00 pm
OLAP Product: Cognos Express 10
Version: CE 10.1.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Active Form error - The clipboard cannot be emptied.

Post by jameswebber » Wed Dec 19, 2012 4:34 am

Apparently fixed in TM1 9.5.2 FP3
http://www-01.ibm.com/support/docview.w ... tus&mync=E

May be a while before this flows down to CE since FP 1 only just came out

User avatar
jameswebber
Community Contributor
Posts: 188
Joined: Sun Nov 21, 2010 8:00 pm
OLAP Product: Cognos Express 10
Version: CE 10.1.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Active Form error - The clipboard cannot be emptied.

Post by jameswebber » Wed Feb 20, 2013 4:18 am

This was working fine for me but stopped working all of a sudden today.

Anyone else got this issue coming back again?

Post Reply