Error 1067 - TM1 9.4/9.5

Error 1067 - TM1 9.4/9.5

Postby Solanna » Sat Apr 24, 2010 3:38 pm

Here's some information that may add value to some folks who have tried to install a TM1 Server manually as a service and get error 1067 when trying to start the server

While the TM1 operations manual attempts to describe the command line using the TM1sd.exe command it unfortunately left out a key part of the command line

The example in the manual:

TM1sd.exe -install -n sdata -z C:\Program Files\Cognos\TM1\Custom\TM1data\sdata

The correct command line should read:

TM1sd.exe -install -n sdata -z "C:\Program Files\Cognos\TM1\Custom\TM1data\sdata"

Those damn little double quotes will make a huge difference!
Who knew! I guess after installing 100's of TM1 servers as application servers, I should have known better and ignored the manual :x

If you leave off the double quotes, the command line will still return an install successful giving you the assumption that all is well
Unfortunately, this isn't the case but I certainly do not expect this to get fixed in any release any time soon

So for any of you that have been banging your head against the wall trying to install a server manually, this will hopefully provide some relief
Solanna
 
Posts: 31
Joined: Thu May 29, 2008 11:20 pm
Location: Redondo Beach, CA USA
OLAP Product: TM1
Version: 9.5.2 to 10.2
Excel Version: 2007 - 2013

Re: Error 1067 - TM1 9.4/9.5

Postby Martin Erlmoser » Thu Apr 29, 2010 5:28 am

i like it short and without any whitespaces.
Martin Erlmoser
Community Contributor
 
Posts: 122
Joined: Wed May 28, 2008 1:22 pm
Location: Vienna
OLAP Product: TM1, Cognos Express,..
Version: 9.1.4 FP1
Excel Version: 2010

Re: Error 1067 - TM1 9.4/9.5

Postby Alan Kirk » Thu Apr 29, 2010 5:50 am

Martin Erlmoser wrote:i like it short and without any whitespaces.


I always thought that it was brain dead of MS to include white spaces in some standard paths (like "Program Files") anyway, but clearly the "user friendliness" brigade won out over the "how could this screw up an app" contingent.

However my recommendation would be that we get well and truly out of the habit of putting the data files in the "C:\Program Files\Cognos\TM1\Custom\" path anyway. As I observed with Vista, the New Generation of O/S's from MS Do Not Like data and program files coexisting in the one location. You can bet that this will be the same with Server 2008 when it becomes a supported platform as well. That means that wherever the data files go, it needs to be somewhere other than a folder on the Program Files path.

And I agree with you, it should be a path which no whitespaces, and no punctuation either. Just good, old, unscrew-up-able alphanumerics.

I did report this as an issue to Cognos and told them that they need to modify their install script to start sticking the data files elsewhere on install in anticipation of this becoming an issue in the post-Server 2003 /Windows XP world, and this was the reply that I got:

The default directory is set by using the system variable %ProgramFiles%. I suspect that on Vista it returns something like C:\Users\MyAccount\AppData\Local\VirtualStore\Program Files\ wher on other windows OS it is C:\Program Files. We probably just need to update how we pass the directory for Vista or use another variable to capture the correct directory path


:roll: {Count to 10, breathe, breathe, patience, understanding, compassion, all that... stuff.}

Nooo... the %ProgramFiles% environment variable still returns the standard program files path in Vista. The problem, as I explained in the request, is that you cannot store data files in there in a Vista / Windows 7 / Server 2008 environment without causing yourself lots and lots of trouble.

Eeeh, they'll figure it out eventually...
"It's only 'hubris' if I fail."
-----------
Before posting, please check the documentation, the FAQ, the Search function and FOR THE LOVE OF GLUB the Request Guidelines.
User avatar
Alan Kirk
Site Admin
 
Posts: 4588
Joined: Sun May 11, 2008 2:30 am
Location: Sydney, Australia
OLAP Product: TM1
Version: 9.5.2 64 bit
Excel Version: XP to 2010

Re: Error 1067 - TM1 9.4/9.5

Postby Martin Erlmoser » Thu Apr 29, 2010 6:01 am

haha, i like answers for never asked questions ;)
Martin Erlmoser
Community Contributor
 
Posts: 122
Joined: Wed May 28, 2008 1:22 pm
Location: Vienna
OLAP Product: TM1, Cognos Express,..
Version: 9.1.4 FP1
Excel Version: 2010


Return to Cognos TM1

Who is online

Users browsing this forum: Bing [Bot] and 3 guests

Loading